CVEvulnerability
CVE-2026-11500
1.3 LOW
Official page ↗
- Status
- Deferred
- Published
- 2026-06-08
- Last modified
- 2026-07-23
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 1.3 LOW — CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 5.0 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 2.0 ([email protected])
- 4.6 MEDIUM — AV:N/AC:H/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-285, CWE-639
Description
A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.
Related
References
- https://github.com/weaviate/weaviate/ github.com
- https://github.com/weaviate/weaviate/commit/40f2cc32279f0f8a51016c3c6870a2c0c808e6c0 github.com
- https://github.com/weaviate/weaviate/issues/11392 github.com
- https://github.com/weaviate/weaviate/releases/tag/v1.38.0-rc.0 github.com
- https://vuldb.com/cve/CVE-2026-11500 vuldb.com
- https://vuldb.com/submit/835080 vuldb.com
- https://vuldb.com/vuln/369120 vuldb.com
- https://vuldb.com/vuln/369120/cti vuldb.com