CVEvulnerability
CVE-2026-115915
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-10-26
- Last modified
- 2026-10-28
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-183, CWE-20
Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.
Affected configurations
• vllm vllm (>= 0.30.0 < 0.32.0)
Related
References
- https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd Patch
- https://github.com/vllm-project/vllm/pull/60022 Patch
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0 Release Notes
- https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h Patch, Vendor Advisory