CVEvulnerability
CVE-2026-115917
4.7 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-10-26
- Last modified
- 2026-10-28
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.4 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 4.7 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:N/A:N
- Weaknesses
- CWE-942
Description
vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.
Affected configurations
• vllm vllm (< 0.32.0)
Related
Weakness · CWE (1)
- CWE-942 Permissive Cross-domain Security Policy with Untrusted Domains weakness
References
- https://github.com/vllm-project/vllm/commit/fcae5c98870ff2c20659731dce7ba3a3ff0d48aa Patch
- https://github.com/vllm-project/vllm/pull/61009 Patch
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0 Release Notes
- https://github.com/vllm-project/vllm/security/advisories/GHSA-vvpg-rrww-wpmh Patch, Vendor Advisory