CVEvulnerability

CVE-2026-119190

7.4 HIGH EPSS 0.25% Published 2026-10-29 Modified 2026-10-30 Official page ↗

Exploitation and prioritisation

EPSS
0.25% chance of exploitation in the next 30 days · in the top 84.1% of all CVEs (2026-11-03)
CISA SSVC: exploitation
poc
CISA SSVC: automatable
no
CISA SSVC: technical impact
total
EU Vulnerability Database
EUVD-2026-113347

Affected packages

EcosystemPackageVulnerableFixed inAdvisory
npmnode-forge< 1.4.11.4.1GHSA-5x38-2vff-x55p
Status
Undergoing Analysis
Published
2026-10-29
Last modified
2026-10-30
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-295, CWE-436

Description

Forge (also called node-forge) is a native implementation of Transport Layer Security in JavaScript. Prior to 1.4.1, node-forge parsed deprecated extension OIDs 2.5.29.10 and 2.5.29.13 as basicConstraints, and pki.verifyCertificateChain() used the first extension with that name. Exploitation requires a CA trusted by the application to issue a certificate carrying an attacker-supplied deprecated-OID extension, commonly because the CA copies extensions from a certificate signing request. By placing a permissive deprecated extension before the genuine 2.5.29.19 basicConstraints extension, the certificate holder could have the certificate accepted as a CA and issue certificates for arbitrary names, enabling server or client impersonation. If the issuing CA adds a keyUsage extension without keyCertSign, node-forge rejects the chain. This issue is fixed in version 1.4.1.

Related

Weakness · CWE (2)

  • CWE-295 Improper Certificate Validation weakness
  • CWE-436 Interpretation Conflict weakness

Referenced by GitHub Advisory · alias (1)

  • GHSA-5x38-2vff-x55p Forge: X.509 basicConstraints bypass in verifyCertificateChain() via deprecated extension OIDs 2.5.29.10 and 2.5.29.13 advisory · npm

References