CVEvulnerability
CVE-2026-11945
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-06-11
- Last modified
- 2026-10-26
- Assigner
- f86ef6dc-4d3a-42ad-8f28-e6d5547a5007
- CVSS 3.1 (f86ef6dc-4d3a-42ad-8f28-e6d5547a5007)
- 6.4 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
Description
PostgreSQL Anonymizer contains a vulnerability that allows a user to gain superuser privileges by creating a JSON document and placing malicious code inside a particular key-value pair. If a superuser calls the import_database_rules() or import_roles_rules() functions, the malicious code is executed with superuser privileges. The problem is resolved in PostgreSQL Anonymizer 3.1.1 and further versions
Affected configurations
• dalibo postgresql anonymizer (< 3.1.1)
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://gitlab.com/dalibo/postgresql_anonymizer/-/issues/643 Exploit, Issue Tracking, Patch, Vendor Advisory