CVEvulnerability

CVE-2026-12957

8.5 HIGH Published 2026-06-23 Modified 2026-10-26 Official page ↗
Status
Awaiting Analysis
Published
2026-06-23
Last modified
2026-10-26
Assigner
ff89ba41-3aa1-4d27-914a-91399e9639e5
CVSS 4.0 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
8.5 HIGH — CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Weaknesses
CWE-732

Description

Improper trust boundary enforcement in Language Servers for AWS before version 1.65.0 on all supported platforms may allow a for arbitrary code execution. If a local user opens a maliciously crafted workspace, any commands within the project configuration files may be automatically executed. This issue requires the user to trust the workspace when prompted. To remediate this issue, users should upgrade to Language Servers for AWS version 1.65.0 or higher.

Related

Weakness · CWE (1)

  • CWE-732 Incorrect Permission Assignment for Critical Resource weakness

References