CVEvulnerability
CVE-2026-1524
2.1 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-11
- Last modified
- 2026-08-28
- Assigner
- 3b236295-4ccd-4a1f-a1c1-a72eecc8d7b6
- CVSS 4.0 (3b236295-4ccd-4a1f-a1c1-a72eecc8d7b6)
- 2.1 LOW — CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:N/R:U/V:D/RE:M/U:Green
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-287, CWE-863
Description
An edgecase in SSO implementation in Neo4j Enterprise edition versions prior to version 2026.02 can lead to unauthorised access under the following conditions:
If a neo4j admin configures two or more OIDC providers AND configures one or more of them to be an authorization provider AND configures one or more of them to be authentication-only, then those that are authentication-only will also provide authorization. This edgecase becomes a security problem only if the authentication-only provider contains groups which have higher privileges than provided by the intended (configured) authorization provider.
When using multiple plugins for authentication and authorisation, prior to the fix the issue could lead to a plugin configured to provide only authentication or authorisation capabilities erroneously providing both capabilities.
We recommend upgrading to versions 2026.02 (or 5.26.22) where the issue is fixed.
Affected configurations
• neo4j neo4j (< 5.26.22)
• neo4j neo4j (>= 2025.01.0 < 2026.02.0)
Related
References
- https://neo4j.com/security/CVE-2026-1524 Vendor Advisory