CVEvulnerability
CVE-2026-15810
8.7 HIGH
Official page ↗
- Status
- Awaiting Analysis
- Published
- 2026-07-24
- Last modified
- 2026-10-24
- Assigner
- f45cbf4e-4146-4068-b7e1-655ffc2c548c
- CVSS 4.0 (f45cbf4e-4146-4068-b7e1-655ffc2c548c)
- 8.7 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:Amber
- Weaknesses
- CWE-79
Description
A Cross-Site Scripting (XSS) vulnerability in Google Cloud Looker versions prior to 25.6.103, 25.12.65, 25.18.68, 26.0.66, 26.2.47, 26.4.36, 26.6.28, and 26.8.7 on Looker-hosted and Self-hosted allows an attacker to execute arbitrary JavaScript leading to administrative account takeover using a maliciously crafted URL.
Looker-hosted and Self-hosted were found to be vulnerable.
This issue has already been mitigated for Looker-hosted instances. No user action is required for these.
Self-hosted instances must be upgraded to the patched versions: 25.6.103+, 25.12.65+, 25.18.68+, 26.0.66+, 26.2.47+, 26.4.36+, 26.6.28+, or 26.8.7+.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://docs.cloud.google.com/looker/docs/release-notes#July_22_2026 docs.cloud.google.com
- https://docs.cloud.google.com/support/bulletins#gcp-2026-049 docs.cloud.google.com