CVEvulnerability

CVE-2026-15996

6.6 MEDIUM Published 2026-08-05 Modified 2026-10-23 Official page ↗
Status
Analyzed
Published
2026-08-05
Last modified
2026-10-23
Assigner
[email protected]
CVSS 4.0 ([email protected])
6.6 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-674

Description

A denial of service vulnerability was identified in GitHub Enterprise Server that allowed an unauthenticated attacker to cause excessive CPU consumption and exhaust the pool of request-handling worker processes by sending a crafted form-encoded HTTP POST request containing deeply nested parameters. Because request parameters were parsed before routing and authentication, any POST endpoint could be used to trigger the condition, which could render the instance unresponsive. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.21 and was fixed in versions 3.20.3, 3.19.7, 3.18.10, and 3.17.16.

Affected configurations

• github enterprise server (< 3.17.16) • github enterprise server (>= 3.18.0 < 3.18.10) • github enterprise server (>= 3.19.0 < 3.19.7) • github enterprise server (>= 3.20.0 < 3.20.3)

Related

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

References