CVEvulnerability

CVE-2026-21896

5.8 MEDIUM Published 2026-01-08 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-01-08
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
5.8 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
5.7 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
Weaknesses
CWE-863

Description

Kirby is an open-source content management system. From versions 5.0.0 to 5.2.1, Kirby is missing permission checks in the content changes API. This vulnerability affects all Kirby sites where user permissions are configured to prevent specific role(s) from performing write actions, specifically by disabling the update permission with the intent to prevent modifications to site content. This vulnerability does not affect those who have not altered the deviated from default user permissions. This issue has been patched in version 5.2.2.

Affected configurations

• getkirby kirby (>= 5.0.0 < 5.2.2)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References