CVEvulnerability
CVE-2026-23630
6.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-01-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 6.3 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-116, CWE-79
Description
Docmost is open-source collaborative wiki and documentation software. In versions 0.3.0 through 0.23.2, Mermaid code block rendering is vulnerable to stored Cross-Site Scripting (XSS). The frontend can render attacker-controlled Mermaid diagrams using mermaid.render(), then inject the returned SVG/HTML into the DOM via dangerouslySetInnerHTML without sanitization. Mermaid per-diagram %%{init}%% directives allow overriding securityLevel and enabling htmlLabels, permitting arbitrary HTML/JS execution for any viewer. This issue has been fixed in version 0.24.0.
Affected configurations
• docmost docmost (>= 0.3.0 < 0.24.0)
Related
References
- https://github.com/docmost/docmost/commit/cb9f27da9a8b4940760e37e5238a1eb91e427daf Patch
- https://github.com/docmost/docmost/releases/tag/v0.24.0 Product, Release Notes
- https://github.com/docmost/docmost/security/advisories/GHSA-r4hj-mc62-jmwj Exploit, Vendor Advisory