CVEvulnerability
CVE-2026-23643
5.4 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-01-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.
Affected configurations
• cakephp cakephp (>= 5.2.10 < 5.2.12)
• cakephp cakephp 5.3.0
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://bakery.cakephp.org/2026/01/14/cakephp_5212.html Product, Release Notes
- https://github.com/cakephp/cakephp/commit/c842e7f45d85696e6527d8991dd72f525ced955f Patch
- https://github.com/cakephp/cakephp/issues/19172 Issue Tracking
- https://github.com/cakephp/cakephp/releases/tag/5.2.12 Product, Release Notes
- https://github.com/cakephp/cakephp/releases/tag/5.3.1 Product, Release Notes
- https://github.com/cakephp/cakephp/security/advisories/GHSA-qh8m-9qxx-53m5 Vendor Advisory