CVEvulnerability
CVE-2026-23981
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-30
- Last modified
- 2026-10-23
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 5.3 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-285
Description
An Improper Authorization vulnerability exists in Apache Superset allowing an authenticated user with permissions to update charts to modify dashboards they do not own. When updating a chart's properties via the REST API, a user can provide a list of dashboard IDs (dashboards) to associate the chart with. The validation logic in the UpdateChartCommand failed to verify that the user had write permissions for the target dashboards specified in the request body.
This issue affects Apache Superset: before 6.0.0.
Users are recommended to upgrade to version 6.0.0, which fixes the issue.
Affected configurations
• apache superset (< 6.0.0)
Related
Weakness · CWE (1)
- CWE-285 Improper Authorization weakness
References
- https://lists.apache.org/thread/k7q9z27t901xvqnkwgyns1l7w1dj3csf Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/07/30/6 Mailing List, Third Party Advisory