CVEvulnerability
CVE-2026-23982
7.1 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-02-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.1 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-863
Description
An Improper Authorization vulnerability exists in Apache Superset that allows a low-privileged user to bypass data access controls. When creating a dataset, Superset enforces permission checks to prevent users from querying unauthorized data. However, an authenticated attacker with permissions to write datasets and read charts can bypass these checks by overwriting the SQL query of an existing dataset.
This issue affects Apache Superset: before 6.0.0.
Users are recommended to upgrade to version 6.0.0, which fixes the issue.
Affected configurations
• apache superset (< 6.0.0)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://lists.apache.org/thread/9lvbzwkw4rxgdvbpfvnnnfcll92v75fp Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/02/24/6 Mailing List, Third Party Advisory