CVEvulnerability
CVE-2026-24098
6.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-02-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
Description
Apache Airflow versions 3.0.0 - 3.1.7, has vulnerability that allows authenticated UI users with permission to one or more specific Dags to view import errors generated by other Dags they did not have access to.
Users are advised to upgrade to 3.1.7 or later, which resolves this issue
Affected configurations
• apache airflow (>= 3.0.0 < 3.1.7)
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://github.com/apache/airflow/pull/60801 Issue Tracking, Patch
- https://lists.apache.org/thread/nx96435v77xdst7ls5lk57kqvqyj095x Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/02/09/3 Mailing List, Third Party Advisory