CVEvulnerability

CVE-2026-24733

3.7 LOW Published 2026-02-17 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2026-02-17
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
3.7 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-20

Description

Improper Input Validation vulnerability in Apache Tomcat. Tomcat did not limit HTTP/0.9 requests to the GET method. If a security constraint was configured to allow HEAD requests to a URI but deny GET requests, the user could bypass that constraint on GET requests by sending a (specification invalid) HEAD request using HTTP/0.9. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0.M1 through 9.0.112. Older, EOL versions are also affected. Users are recommended to upgrade to version 11.0.15 or later, 10.1.50 or later or 9.0.113 or later, which fixes the issue.

Affected configurations

• apache tomcat (>= 9.0.1 < 9.0.113) • apache tomcat (>= 10.1.1 < 10.1.50) • apache tomcat (>= 11.0.1 < 11.0.15) • apache tomcat 9.0.0 • apache tomcat 10.0.0 • apache tomcat 11.0.0

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References