CVEvulnerability

CVE-2026-24734

7.5 HIGH Published 2026-02-17 Modified 2026-07-15 Official page ↗
Status
Modified
Published
2026-02-17
Last modified
2026-07-15
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-20, CWE-295

Description

Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native:  from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.

Affected configurations

• apache tomcat (>= 9.0.83 < 9.0.115) • apache tomcat (>= 10.1.1 < 10.1.52) • apache tomcat (>= 11.0.1 < 11.0.18) • apache tomcat 10.1.0 • apache tomcat 11.0.0 • apache tomcat native (>= 1.3.0 < 1.3.5) • apache tomcat native (>= 2.0.0 < 2.0.12)

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-295 Improper Certificate Validation weakness

References