CVEvulnerability
CVE-2026-25958
7.7 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-02-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-807
Description
Cube is a semantic layer for building data applications. From 0.27.19 to before 1.5.13, 1.4.2, and 1.0.14, it is possible to make a specially crafted request with a valid API token that leads to privilege escalation. This vulnerability is fixed in 1.5.13, 1.4.2, and 1.0.14.
Affected configurations
• cube cube.js (>= 0.27.19 < 1.0.14)
• cube cube.js (>= 1.1.0 < 1.4.2)
• cube cube.js (>= 1.5.0 < 1.5.13)
Related
Weakness · CWE (1)
- CWE-807 Reliance on Untrusted Inputs in a Security Decision weakness