CVEvulnerability
CVE-2026-26989
4.8 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-02-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 4.8 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
LibreNMS is an auto-discovering PHP/MySQL/SNMP based network monitoring tool. Versions 25.12.0 and below are affected by a Stored Cross-Site Scripting (XSS) vulnerability in the Alert Rules workflow. An attacker with administrative privileges can inject malicious scripts that execute in the browser context of any user who accesses the Alert Rules page. This issue has been fixed in version 26.2.0.
Affected configurations
• librenms librenms (< 26.2.0)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/librenms/librenms/commit/087608cf9f851189847cb8e8e5ad002e59170c58 Patch
- https://github.com/librenms/librenms/pull/19039 Issue Tracking
- https://github.com/librenms/librenms/releases/tag/26.2.0 Product, Release Notes
- https://github.com/librenms/librenms/security/advisories/GHSA-6xmx-xr9p-58p7 Exploit, Third Party Advisory