CVEvulnerability
CVE-2026-27801
6.0 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 6.0 MEDIUM — CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:H/A:N
- Weaknesses
- CWE-307
Description
Vaultwarden is an unofficial Bitwarden compatible server written in Rust, formerly known as bitwarden_rs. Vaultwarden versions 1.34.3 and prior are susceptible to a 2FA bypass when performing protected actions. An attacker who gains authenticated access to a user’s account can exploit this bypass to perform protected actions such as accessing the user’s API key or deleting the user’s vault and organisations the user is an admin/owner of . This issue has been patched in version 1.35.0.
Affected configurations
• dani-garcia vaultwarden (< 1.35.0)
Related
Weakness · CWE (1)
- CWE-307 Improper Restriction of Excessive Authentication Attempts weakness
References
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-v6pg-v89r-w8wr Exploit, Mitigation, Vendor Advisory
- https://github.com/dani-garcia/vaultwarden/security/advisories/GHSA-v6pg-v89r-w8wr Exploit, Mitigation, Vendor Advisory