CVEvulnerability
CVE-2026-28384
9.4 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-12
- Last modified
- 2026-09-18
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 9.4 CRITICAL — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.9 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-78
Description
An improper sanitization of the compression_algorithm parameter in Canonical LXD allows an authenticated, unprivileged user to execute commands as the LXD daemon on the LXD server via API calls to the image and backup endpoints. This issue affected LXD from 4.12 through 6.6 and was fixed in the snap versions 5.0.6-e49d9f4 (channel 5.0/stable), 5.21.4-1374f39 (channel 5.21/stable), and 6.7-1f11451 (channel 6.0 stable). The channel 4.0/stable is not affected as it contains version 4.0.10.
Affected configurations
• canonical lxd (>= 4.12 < 5.0.6)
• canonical lxd (>= 5.21.0 < 5.21.4)
• canonical lxd (>= 6.0 < 6.7)
Related
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://discourse.ubuntu.com/t/lxd-authenticated-remote-code-execution-fixes-available/78365 Issue Tracking, Exploit, Vendor Advisory
- https://github.com/canonical/lxd/commit/043696a13171ace7dd4c2b32d34ce039ab629052 Patch
- https://github.com/canonical/lxd/commit/7046979645c2ce1b63b2f9e60ddf6cbc4c4b78f9 Patch
- https://github.com/canonical/lxd/commit/b7b411caf5c4971bfe2386c72128f44d7e2aaf4f Patch
- https://github.com/canonical/lxd/security/advisories/GHSA-4rmf-rcp8-2r9g Vendor Advisory, Exploit
- https://github.com/canonical/lxd/security/advisories/GHSA-4rmf-rcp8-2r9g Vendor Advisory, Exploit