CVEvulnerability
CVE-2026-28513
7.1 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
- CVSS 3.1 ([email protected])
- 7.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
- Weaknesses
- CWE-863
Description
Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to your services. Prior to 2.4.0, the OIDC token endpoint rejects an authorization code only when both the client ID is wrong and the code is expired. This allows cross-client code exchange and expired code reuse. This vulnerability is fixed in 2.4.0.
Affected configurations
• pocket-id pocket id (< 2.4.0)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/pocket-id/pocket-id/security/advisories/GHSA-qh6q-598w-w6m2 Exploit, Vendor Advisory
- https://github.com/pocket-id/pocket-id/security/advisories/GHSA-qh6q-598w-w6m2 Exploit, Vendor Advisory