CVEvulnerability
CVE-2026-29091
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2026-03-06
- Last modified
- 2026-07-15
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94, CWE-95
Description
Locutus brings stdlibs of other programming languages to JavaScript for educational purposes. Prior to version 3.0.0, a remote code execution (RCE) flaw was discovered in the locutus project, specifically within the call_user_func_array function implementation. The vulnerability allows an attacker to inject arbitrary JavaScript code into the application's runtime environment. This issue stems from an insecure implementation of the call_user_func_array function (and its wrapper call_user_func), which fails to properly validate all components of a callback array before passing them to eval(). This issue has been patched in version 3.0.0.
Affected configurations
• locutus locutus (< 3.0.0)
Related
References
- https://github.com/locutusjs/locutus/commit/977a1fb169441e35996a1d2465b512322de500ad Patch
- https://github.com/locutusjs/locutus/security/advisories/GHSA-fp25-p6mj-qqg6 Exploit, Mitigation, Vendor Advisory
- https://access.redhat.com/security/cve/CVE-2026-29091 access.redhat.com
- https://bugzilla.redhat.com/show_bug.cgi?id=2445262 bugzilla.redhat.com
- https://github.com/locutusjs/locutus/security/advisories/GHSA-fp25-p6mj-qqg6 Exploit, Mitigation, Vendor Advisory
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-29091.json security.access.redhat.com