CVEvulnerability

CVE-2026-29145

9.1 CRITICAL Published 2026-04-09 Modified 2026-10-26 Official page ↗
Status
Analyzed
Published
2026-04-09
Last modified
2026-10-26
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-287

Description

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled vulnerability in Apache Tomcat, Apache Tomcat Native. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.1.0-M7 through 10.1.52, from 9.0.83 through 9.0.115; Apache Tomcat Native: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39, from 1.3.0 through 1.3.6, from 2.0.0 through 2.0.13. Users are recommended to upgrade to version Tomcat Native 1.3.7 or 2.0.14 and Tomcat 11.0.20, 10.1.53 and 9.0.116, which fix the issue.

Affected configurations

• apache tomcat (>= 9.0.83 < 9.0.116) • apache tomcat (>= 10.1.1 < 10.1.53) • apache tomcat (>= 11.0.0 < 11.0.20) • apache tomcat 10.1.0 • apache tomcat native (>= 1.1.23 < 1.3.7) • apache tomcat native (>= 2.0.0 < 2.0.14)

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References