CVEvulnerability

CVE-2026-29146

7.5 HIGH Published 2026-04-09 Modified 2026-10-26 Official page ↗
Status
Modified
Published
2026-04-09
Last modified
2026-10-26
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-1240, CWE-209, CWE-642

Description

Padding Oracle vulnerability in Apache Tomcat's EncryptInterceptor with default configuration. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.18, from 10.0.0-M1 through 10.1.52, from 9.0.13 through 9..115, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109. Users are recommended to upgrade to version 11.0.19, 10.1.53 and 9.0.116, which fixes the issue.

Affected configurations

• apache tomcat (>= 7.0.100 <= 7.0.109) • apache tomcat (>= 8.5.38 <= 8.5.100) • apache tomcat (>= 9.0.13 < 9.0.116) • apache tomcat (>= 10.0.0 < 10.1.53) • apache tomcat (>= 11.0.0 < 11.0.20)

Related

Weakness · CWE (3)

  • CWE-1240 Use of a Cryptographic Primitive with a Risky Implementation weakness
  • CWE-209 Generation of Error Message Containing Sensitive Information weakness
  • CWE-642 External Control of Critical State Data weakness

References