CVEvulnerability
CVE-2026-2996
7.5 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2026-08-22
- Last modified
- 2026-10-12
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- Weaknesses
- CWE-20
Description
The Advanced Product Fields (Product Addons) for WooCommerce plugin for WordPress is vulnerable to Improper Input Validation in all versions up to, and including, 1.6.21. This is due to a logic flaw in the 'validate_cart_data' function. This makes it possible for unauthenticated attackers to bypass required paid addons and complete purchases at the base product price only, effectively stealing products by paying a fraction of the intended total. The vulnerability was partially patched in version 1.6.19.
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://plugins.trac.wordpress.org/browser/advanced-product-fields-for-woocommerce/trunk/includes/controllers/class-product-controller.php#L130 plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/changeset/3477476/ plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/changeset/3483410/ plugins.trac.wordpress.org
- https://www.wordfence.com/threat-intel/vulnerabilities/id/5d9c1c3d-6882-4425-8d32-bdb57b4f133d?source=cve www.wordfence.com