CVEvulnerability
CVE-2026-30851
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-07
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-287, CWE-345
Description
Caddy is an extensible server platform that uses TLS by default. From version 2.10.0 to before version 2.11.2, forward_auth copy_headers does not strip client-supplied headers, allowing identity injection and privilege escalation. This issue has been patched in version 2.11.2.
Affected configurations
• caddyserver caddy (>= 2.10.0 < 2.11.2)
Related
References
- https://github.com/caddyserver/caddy/issues/6610 Issue Tracking
- https://github.com/caddyserver/caddy/pull/6608 Issue Tracking, Patch
- https://github.com/caddyserver/caddy/pull/7545 Issue Tracking, Patch
- https://github.com/caddyserver/caddy/security/advisories/GHSA-7r4p-vjf4-gxv4 Exploit, Mitigation, Patch, Vendor Advisory