CVEvulnerability

CVE-2026-30874

1.8 LOW Published 2026-03-19 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-03-19
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
1.8 LOW — CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-187, CWE-269, CWE-74

Description

OpenWrt Project is a Linux operating system targeting embedded devices. In versions prior to 24.10.6, a vulnerability in the hotplug_call function allows an attacker to bypass environment variable filtering and inject an arbitrary PATH variable, potentially leading to privilege escalation. The function is intended to filter out sensitive environment variables like PATH when executing hotplug scripts in /etc/hotplug.d, but a bug using strcmp instead of strncmp causes the filter to compare the full environment string (e.g., PATH=/some/value) against the literal "PATH", so the match always fails. As a result, the PATH variable is never excluded, enabling an attacker to control which binaries are executed by procd-invoked scripts running with elevated privileges. This issue has been fixed in version 24.10.6.

Affected configurations

• openwrt openwrt (< 24.10.6)

Related

Weakness · CWE (3)

  • CWE-187 Partial String Comparison weakness
  • CWE-269 Improper Privilege Management weakness
  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References