CVEvulnerability
CVE-2026-30949
7.6 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.6 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-287
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.5 and 8.6.18, the Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms. All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected. This vulnerability is fixed in 9.5.2-alpha.5 and 8.6.18.
Affected configurations
• parseplatform parse-server (< 8.6.18)
• parseplatform parse-server (>= 9.0.0 < 9.5.2)
• parseplatform parse-server 9.5.2
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://github.com/parse-community/parse-server/releases/tag/8.6.18 Product, Release Notes
- https://github.com/parse-community/parse-server/releases/tag/9.5.2-alpha.5 Product, Release Notes
- https://github.com/parse-community/parse-server/security/advisories/GHSA-48mh-j4p5-7j9v Patch, Vendor Advisory