CVEvulnerability

CVE-2026-30967

7.6 HIGH Published 2026-03-10 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-03-10
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.6 HIGH — CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.9. and 8.6.22, the OAuth2 authentication adapter, when configured without the useridField option, only verifies that a token is active via the provider's token introspection endpoint, but does not verify that the token belongs to the user identified by authData.id. An attacker with any valid OAuth2 token from the same provider can authenticate as any other user. This affects any Parse Server deployment that uses the generic OAuth2 authentication adapter (configured with oauth2: true) without setting the useridField option. This vulnerability is fixed in 9.5.2-alpha.9. and 8.6.22.

Affected configurations

• parseplatform parse-server (< 8.6.22) • parseplatform parse-server (>= 9.0.0 < 9.5.2) • parseplatform parse-server 9.5.2

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References