CVEvulnerability

CVE-2026-31908

9.1 CRITICAL Published 2026-04-14 Modified 2026-10-26 Official page ↗
Status
Analyzed
Published
2026-04-14
Last modified
2026-10-26
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-75

Description

Header injection vulnerability in Apache APISIX. The attacker can take advantage of certain configuration in forward-auth plugin to inject malicious headers. This issue affects Apache APISIX: from 2.12.0 through 3.15.0. Users are recommended to upgrade to version 3.16.0, which fixes the issue.

Affected configurations

• apache apisix (>= 2.12.0 < 3.16.0)

Related

Weakness · CWE (1)

  • CWE-75 Failure to Sanitize Special Elements into a Different Plane weakness

References