CVEvulnerability

CVE-2026-32269

6.3 MEDIUM Published 2026-03-12 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-03-12
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
6.3 MEDIUM — CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-683

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.6.0-alpha.13 and 8.6.39, the OAuth2 authentication adapter does not correctly validate app IDs when appidField and appIds are configured. During app ID validation, a malformed value is sent to the token introspection endpoint instead of the user's actual access token. Depending on the introspection endpoint's behavior, this could either cause all OAuth2 logins to fail, or allow authentication from disallowed app contexts if the endpoint returns valid-looking data for the malformed request. Deployments using the OAuth2 adapter with appidField and appIds configured are affected. This vulnerability is fixed in 9.6.0-alpha.13 and 8.6.39.

Affected configurations

• parseplatform parse-server (>= 8.0.2 < 8.6.39) • parseplatform parse-server (>= 9.0.0 < 9.6.0) • parseplatform parse-server 9.6.0

Related

Weakness · CWE (1)

  • CWE-683 Function Call With Incorrect Order of Arguments weakness

References