CVEvulnerability
CVE-2026-32327
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-08-06
- Last modified
- 2026-10-24
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- Weaknesses
- CWE-674
Description
A bug in APR-util version 1.6.3 (and earlier) allows a stack recursion attack against any library consumer which parses XML from untrusted sources and uses the apr_xml_quote_elem() function.
Users are recommended to upgrade to version 1.6.4, which fixes this issue.
Affected configurations
• apache apr-util (< 1.6.4)
Related
Weakness · CWE (1)
- CWE-674 Uncontrolled Recursion weakness
References
- https://lists.apache.org/thread/hq27vj8yfno9tkwv0fpj6jksfzgxvth1 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2026/08/06/9 Mailing List, Third Party Advisory