CVEvulnerability

CVE-2026-32794

4.8 MEDIUM Published 2026-03-30 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-03-30
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
4.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-295

Description

Improper Certificate Validation vulnerability in Apache Airflow Provider for Databricks. Provider code did not validate certificates for connections to Databricks back-end which could result in a man-of-a-middle attack that traffic is intercepted and manipulated or credentials exfiltrated w/o notice. This issue affects Apache Airflow Provider for Databricks: from 1.10.0 before 1.12.0. Users are recommended to upgrade to version 1.12.0, which fixes the issue.

Affected configurations

• apache airflow providers databricks (>= 1.10.0 < 1.12.0)

Related

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References