CVEvulnerability
CVE-2026-33327
7.0 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-07-20
- Last modified
- 2026-08-19
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 7.0 HIGH — CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-190
Description
libvips is a fast image processing library with low memory needs. The `vipsload` operation in versions before and including 8.18.0 could incorrectly determine image dimensions leading to an integer overflow and a subsequent heap-based buffer overflow. This has been patched in version 8.18.1.
Affected configurations
• libvips libvips (< 8.18.1)
Related
Weakness · CWE (1)
- CWE-190 Integer Overflow or Wraparound weakness
References
- https://github.com/libvips/libvips/commit/61e71c13328ed72d0a530dffc19b9b225072bdf9 Patch
- https://github.com/libvips/libvips/pull/4934 Issue Tracking, Patch
- https://github.com/libvips/libvips/security/advisories/GHSA-2fcj-gj27-279x Vendor Advisory, Mitigation