CVEvulnerability

CVE-2026-3336

8.7 HIGH Published 2026-03-02 Modified 2026-07-15 Official page ↗
Status
Modified
Published
2026-03-02
Last modified
2026-07-15
Assigner
ff89ba41-3aa1-4d27-914a-91399e9639e5
CVSS 4.0 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
8.7 HIGH — CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 (ff89ba41-3aa1-4d27-914a-91399e9639e5)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-295

Description

Improper certificate validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass certificate chain verification when processing PKCS7 objects with multiple signers, except the final signer. Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0.

Affected configurations

• amazon aws-lc-sys (>= 0.24.0 < 0.38.0) • amazon aws libcrypto (>= 1.41.0 < 1.69.0)

Related

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References