CVEvulnerability

CVE-2026-33409

7.0 HIGH Published 2026-03-24 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-03-24
Last modified
2026-06-17
Assigner
[email protected]
CVSS 4.0 ([email protected])
7.0 HIGH — CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
CVSS 3.1 ([email protected])
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-287

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.52 and 9.6.0-alpha.41, an authentication bypass vulnerability allows an attacker to log in as any user who has linked a third-party authentication provider, without knowing the user's credentials. The attacker only needs to know the user's provider ID to gain full access to their account, including a valid session token. This affects Parse Server deployments where the server option allowExpiredAuthDataToken is set to true. The default value is false. This issue has been patched in versions 8.6.52 and 9.6.0-alpha.41.

Affected configurations

• parseplatform parse-server (< 8.6.52) • parseplatform parse-server (>= 9.0.0 < 9.6.0) • parseplatform parse-server 9.6.0

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References