CVEvulnerability
CVE-2026-33527
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 5.3 MEDIUM — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-863
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.57 and 9.6.0-alpha.48, an authenticated user can overwrite server-generated session fields such as expiresAt and createdWith when updating their own session via the REST API. This allows bypassing the server's configured session lifetime policy, making a session effectively permanent. This issue has been patched in versions 8.6.57 and 9.6.0-alpha.48.
Affected configurations
• parseplatform parse-server (< 8.6.57)
• parseplatform parse-server (>= 9.0.0 < 9.6.0)
• parseplatform parse-server 9.6.0
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/parse-community/parse-server/commit/26b628c8fb3cc79ea955374769eebcff6f8a8a73 Patch
- https://github.com/parse-community/parse-server/commit/ea68fc0b22a6056c9675149469ff57817f7cf984 Patch
- https://github.com/parse-community/parse-server/pull/10263 Issue Tracking
- https://github.com/parse-community/parse-server/pull/10264 Issue Tracking
- https://github.com/parse-community/parse-server/security/advisories/GHSA-jc39-686j-wp6q Vendor Advisory