CVEvulnerability
CVE-2026-33642
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-19
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.9 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-125, CWE-190, CWE-787
Description
Kitty is a cross-platform GPU based terminal. In versions 0.46.2 and below, the handle_compose_command() function in kitty/graphics.c performs bounds validation on composition offsets using unsigned 32-bit arithmetic that is subject to integer wrapping, potentially leading to Heap Buffer Over-Read/Write. An attacker who can write escape sequences to a kitty terminal (e.g., via a malicious file, SSH login banner, or piped content) can supply crafted x_offset/y_offset values that pass the bounds check after wrapping but cause massive out-of-bounds heap memory access in compose_rectangles(). No user interaction is required. No non-default configuration is required. The attacker only needs the ability to produce output in a kitty terminal window. This issue has been fixed in version 0.47.0.
Affected configurations
• kovidgoyal kitty (< 0.47.0)
Related
References
- https://github.com/kovidgoyal/kitty/commit/e9661f0f3afb4e4dbffa509adfb3df3c9780ad34 Patch
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-qfgm-2c64-6x3x Exploit, Mitigation, Vendor Advisory
- https://github.com/kovidgoyal/kitty/security/advisories/GHSA-qfgm-2c64-6x3x Exploit, Mitigation, Vendor Advisory