CVEvulnerability
CVE-2026-33762
2.8 LOW
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-31
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 2.8 LOW — CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-129
Description
go-git is an extensible git implementation library written in pure Go. Prior to version 5.17.1, go-git’s index decoder for format version 4 fails to validate the path name prefix length before applying it to the previously decoded path name. A maliciously crafted index file can trigger an out-of-bounds slice operation, resulting in a runtime panic during normal index parsing. This issue only affects Git index format version 4. Earlier formats (go-git supports only v2 and v3) are not vulnerable to this issue. This issue has been patched in version 5.17.1.
Affected configurations
• go-git project go-git (< 5.17.1)
Related
Weakness · CWE (1)
- CWE-129 Improper Validation of Array Index weakness
References
- https://github.com/go-git/go-git/releases/tag/v5.17.1 Product, Release Notes
- https://github.com/go-git/go-git/security/advisories/GHSA-gm2x-2g9h-ccm8 Vendor Advisory