CVEvulnerability
CVE-2026-33804
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-04-16
- Last modified
- 2026-06-17
- Assigner
- ce714d77-add3-4f53-aff5-83d477b104bb
- CVSS 3.1 (ce714d77-add3-4f53-aff5-83d477b104bb)
- 7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-436
Description
@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.
Affected configurations
• fastify fastify\/middie (< 9.3.2)
Related
Weakness · CWE (1)
- CWE-436 Interpretation Conflict weakness
References
- https://cna.openjsf.org/security-advisories.html Vendor Advisory
- https://github.com/fastify/middie/security/advisories/GHSA-v9ww-2j6r-98q6 Mitigation, Vendor Advisory