CVEvulnerability
CVE-2026-33997
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2026-03-31
- Last modified
- 2026-09-09
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- CVSS 3.1 (0b0ca135-0b70-47e7-9f44-1890c2a1c46c)
- 8.4 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-193, CWE-266
Description
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows plugins privilege validation to be bypassed during docker plugin install. Due to an error in the daemon's privilege comparison logic, the daemon may incorrectly accept a privilege set that differs from the one approved by the user. Plugins that request exactly one privilege are also affected, because no comparison is performed at all. This issue has been patched in version 29.3.1.
Affected configurations
• docker engine (< 29.3.1)
Related
References
- https://github.com/moby/moby/releases/tag/docker-v29.3.1 Release Notes
- https://github.com/moby/moby/security/advisories/GHSA-pxq6-2prw-chj9 Vendor Advisory
- https://access.redhat.com/errata/RHSA-2026:21769 access.redhat.com
- https://access.redhat.com/errata/RHSA-2026:22347 access.redhat.com
- https://access.redhat.com/errata/RHSA-2026:23345 access.redhat.com
- https://access.redhat.com/security/cve/CVE-2026-33997 access.redhat.com
- https://bugzilla.redhat.com/show_bug.cgi?id=2453277 bugzilla.redhat.com
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-33997.json security.access.redhat.com