CVEvulnerability
CVE-2026-34084
9.2 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-05-05
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 9.2 CRITICAL — CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502, CWE-918
Description
PhpSpreadsheet is a library for reading and writing spreadsheet files. In versions 1.30.2 and earlier, 2.0.0 through 2.1.14, 2.2.0 through 2.4.3, 3.3.0 through 3.10.3, and 4.0.0 through 5.5.0, when the filename argument to IOFactory::load() is user-controlled, an attacker can supply a PHP stream wrapper path (such as phar://, ftp://, or ssh2.sftp://) that passes the is_file() check in File::assertFile(). The phar:// wrapper triggers deserialization of the PHAR metadata, which can lead to remote code execution if a suitable gadget chain is available in the application. The ftp:// and ssh2.sftp:// wrappers can be used for server-side request forgery. This issue has been fixed in versions 1.30.3, 2.1.15, 2.4.4, 3.10.4, and 5.6.0.
Affected configurations
• phpoffice phpspreadsheet (< 1.30.3)
• phpoffice phpspreadsheet (>= 2.0.0 < 2.1.15)
• phpoffice phpspreadsheet (>= 2.2.0 < 2.4.4)
• phpoffice phpspreadsheet (>= 3.3.0 < 3.10.4)
• phpoffice phpspreadsheet (>= 4.0.0 < 5.6.0)
Related
References
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-q4q6-r8wh-5cgh Exploit, Mitigation, Vendor Advisory
- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-q4q6-r8wh-5cgh Exploit, Mitigation, Vendor Advisory