CVEvulnerability
CVE-2026-34163
7.7 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2026-03-31
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 7.7 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
- Weaknesses
- CWE-918
Description
FastGPT is an AI Agent building platform. Prior to version 4.14.9.5, FastGPT's MCP (Model Context Protocol) tools endpoints (/api/core/app/mcpTools/getTools and /api/core/app/mcpTools/runTool) accept a user-supplied URL parameter and make server-side HTTP requests to it without validating whether the URL points to an internal/private network address. Although the application has a dedicated isInternalAddress() function for SSRF protection (used in other endpoints like the HTTP workflow node), the MCP tools endpoints do not call this function. An authenticated attacker can use these endpoints to scan internal networks, access cloud metadata services, and interact with internal services such as MongoDB and Redis. This issue has been patched in version 4.14.9.5.
Affected configurations
• fastgpt fastgpt (< 4.14.9.5)
Related
Weakness · CWE (1)
- CWE-918 Server-Side Request Forgery weakness
References
- https://github.com/labring/FastGPT/commit/bc7eae2ed61481a5e322208829be291faec58c00 Patch
- https://github.com/labring/FastGPT/pull/6640 Issue Tracking, Patch
- https://github.com/labring/FastGPT/releases/tag/v4.14.9.5 Product, Release Notes
- https://github.com/labring/FastGPT/security/advisories/GHSA-x9vj-5m4j-9mfv Exploit, Mitigation, Vendor Advisory