CVEvulnerability
CVE-2026-34236
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-04-01
- Last modified
- 2026-10-26
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.2 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-331
Description
Auth0-PHP is a PHP SDK for Auth0 Authentication and Management APIs. From version 8.0.0 to before version 8.19.0, in applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. This issue has been patched in version 8.19.0.
Affected configurations
• auth0 auth0-php (>= 8.0.0 < 8.19.0)
Related
Weakness · CWE (1)
- CWE-331 Insufficient Entropy weakness
References
- https://github.com/auth0/auth0-PHP/releases/tag/8.19.0 Product, Release Notes
- https://github.com/auth0/auth0-PHP/security/advisories/GHSA-w3wc-44p4-m4j7 Vendor Advisory