CVEvulnerability

CVE-2026-34884

9.8 CRITICAL Published 2026-08-18 Modified 2026-10-22 Official page ↗
Status
Analyzed
Published
2026-08-18
Last modified
2026-10-22
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-918

Description

SSRF via set_skywalking_url Tool and GraphQL expression injection vulnerability in Apache SkyWalking MCP. This issue affects Apache SkyWalking MCP: 0.1.0. Users are recommended to upgrade to version 0.2.0, which fixes this issue.

Affected configurations

• apache skywalking mcp (>= 0.1.0 < 0.2.0)

Related

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References