CVEvulnerability
CVE-2026-35197
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2026-04-06
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.6 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
dye is a portable and respectful color library for shell scripts. Prior to 1.1.1, certain dye template expressions would result in execution of arbitrary code. This issue was discovered and fixed by dye's author, and is not known to be exploited. This vulnerability is fixed in 1.1.1.
Affected configurations
• mattiebee dye 1.1.0
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://github.com/mattieb/dye/security/advisories/GHSA-3v4r-5vfh-3wjr Vendor Advisory
- https://mattiebee.io/dye-template-advisory Exploit, Vendor Advisory