CVEvulnerability
CVE-2026-39380
5.4 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2026-04-07
- Last modified
- 2026-07-24
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Stock Locations configuration feature. The application fails to properly sanitize user input supplied through the stock_location parameter, allowing attackers to inject malicious JavaScript code that is stored in the database and executed when rendered in the Employees interface. This vulnerability is fixed in 3.4.3.
Affected configurations
• opensourcepos open source point of sale (< 3.4.3)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/opensourcepos/opensourcepos/security/advisories/GHSA-7hg5-68rx-xpmg Exploit, Vendor Advisory
- https://github.com/opensourcepos/opensourcepos/security/advisories/GHSA-7hg5-68rx-xpmg Exploit, Vendor Advisory