CVEvulnerability

CVE-2026-40155

5.4 MEDIUM Published 2026-04-17 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2026-04-17
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.4 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:L/A:N
Weaknesses
CWE-362, CWE-863

Description

The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.

Affected configurations

• auth0 nextjs-auth0 (>= 4.12.0 < 4.18.0)

Related

Weakness · CWE (2)

  • CWE-362 Concurrent Execution using Shared Resource with Improper Synchronization weakness
  • CWE-863 Incorrect Authorization weakness

References