CVEvulnerability
CVE-2026-40194
3.7 LOW
Official page ↗
- Status
- Modified
- Published
- 2026-04-10
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.7 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-208
Description
phpseclib is a PHP secure communications library. Starting in 0.1.1 and prior to 3.0.51, 2.0.53, and 1.0.28, phpseclib\Net\SSH2::get_binary_packet() uses PHP's != operator to compare a received SSH packet HMAC against the locally computed HMAC. != on equal-length binary strings in PHP uses memcmp(), which short-circuits on the first differing byte. This is a real variable-time comparison (CWE-208), proven by scaling benchmarks. This vulnerability is fixed in 3.0.51, 2.0.53, and 1.0.28.
Affected configurations
• phpseclib phpseclib (<= 1.0.27)
• phpseclib phpseclib (>= 2.0.0 < 2.0.53)
• phpseclib phpseclib (>= 3.0.0 < 3.0.51)
Related
Weakness · CWE (1)
- CWE-208 Observable Timing Discrepancy weakness
References
- https://github.com/phpseclib/phpseclib/commit/ffe48b6b1b1af6963327f0a5330e3aa004a194ac Patch
- https://github.com/phpseclib/phpseclib/releases/tag/1.0.28 Release Notes
- https://github.com/phpseclib/phpseclib/releases/tag/2.0.53 Release Notes
- https://github.com/phpseclib/phpseclib/releases/tag/3.0.51 Release Notes
- https://github.com/phpseclib/phpseclib/security/advisories/GHSA-r854-jrxh-36qx Vendor Advisory
- https://github.com/phpseclib/phpseclib/security/advisories/GHSA-r854-jrxh-36qx Vendor Advisory